WordPress.org

Making WordPress.org

#3911 closed defect (fixed)

WordCamp Application Status page: Not all applications are shown

Reported by: coreymckrill Owned by: vedjain
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: needs-patch
Cc:

Description

Currently, the application status table is showing 54 applications, but there should be closer to 120. It seems that the list is alphabetical by city name, but it cuts off after N. On the page source, the JSON variable that is being passed to the table script also cuts off after N, so it seems that the problem is somewhere in the PHP that generates the JSON.

More discussion:
https://wordpress.slack.com/archives/C08M59V3P/p1541498223002200

Change History (2)

This ticket was mentioned in Slack in #meta-wordcamp by coreymckrill. View the logs.


10 months ago

#2 @vedjain
10 months ago

  • Owner set to vedjain
  • Resolution set to fixed
  • Status changed from new to closed

In 7841:

WordCamp: Use `_status_change_log_%' to filter WordCamp Applications.

On WordCamp Application Status report page, we were fetching 300 WordCamp posts, iterating over them one by one and figuring out if we should show in the report.
Changed this to directly filter in database for the posts that we want to show. This allows us to limit the 300 limit as we are already querying in the Database.

Fixes #3911

Note: See TracTickets for help on using tickets.