WordPress.org

Making WordPress.org

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#3924 closed defect (fixed)

Hover issue in the Handbook pages (possibly a regression)

Reported by: Rahmohn Owned by: coffee2code
Milestone: Priority: normal
Component: Handbooks Keywords:
Cc:

Description (last modified by SergeyBiryukov)

In the Handbook pages, there is a conflict between these styles below.

.menu-table-of-contents-container > ul > li.open > div > a:hover {
    color: #fff;
}

.menu-table-of-contents-container ul a.active, 
.menu-table-of-contents-container .current-menu-item > a {
    color: #555;
    background-color: #fff;
}

Because of that while hovering active item the text and background get white. Example: https://wordpress.org/gutenberg/handbook/language/ (hover The Language of Gutenberg item).

This issue was reported and closed 10 months ago in ticket #3400 so I think that occurred a regression.

Attachments (1)

handbook issue.png (36.9 KB) - added by Rahmohn 12 months ago.

Download all attachments as: .zip

Change History (5)

#1 @coffee2code
12 months ago

  • Owner set to coffee2code
  • Status changed from new to accepted

#2 @coffee2code
12 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 7849:

Gutenberg: Fix handbook 'Chapters' menu current item background color on hover.

Props Rahmohn.
Fixes #3924.

#3 @SergeyBiryukov
12 months ago

  • Component changed from General to Handbooks
  • Description modified (diff)

#4 @coffee2code
12 months ago

And for a little clarification: this isn't technically a regression. While it is the same issue as in #3400, the styles causing the issue are theme-specific. The handbooks affected in #3400 use the Breathe theme, whereas Gutenberg uses its own theme.

(But thanks for pointing out the related ticket!)

Note: See TracTickets for help on using tickets.