WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 7 months ago

#3967 closed enhancement (duplicate)

Change or add to link to localized theme/plugin page from theme/plugin translation thee/plugin page

Reported by: knutsp Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Examples:

This pagehttps://wordpress.org/themes/ascend/ links to WordPress.org Theme Pagehttps://wordpress.org/themes/ascend/
This pagehttps://translate.wordpress.org/locale/nb/default/wp-plugins/tablepress links to WordPress.org Plugin Pagehttps://wordpress.org/plugins/tablepress/

In this case (locale: nb) the links should be:
WordPress.org Theme Pagehttps://nb.wordpress.org/themes/ascend/
WordPress.org Plugin Page https://nb.wordpress.org/plugins/tablepress/

Change History (2)

#1 @garrett-eclipse
7 months ago

Just to clarify as this was discussed on Slack;
https://wordpress.slack.com/archives/C0341VCNL/p1543604083000200

This example has the incorrect URLs;

"This page https://wordpress.org/themes/ascend/ links to WordPress.org Theme Page https://wordpress.org/themes/ascend/"

It should be;

"This page https://translate.wordpress.org/locale/nb/default/wp-themes/ascend links to WordPress.org Theme Page https://wordpress.org/themes/ascend/"

And to clarify the desire is that the locale specific pages for projects (themes/plugins) on translate.wp.org which provide links to the project pages (wp.org/themes or wp.org/plugins) should use the locale specific URL which is the language subdomain as seen in the description;
Locale Specific WordPress.org Theme Page https://nb.wordpress.org/themes/ascend/
Locale Specific WordPress.org Plugin Page https://nb.wordpress.org/plugins/tablepress/

Here's some locations that I found for these links...

'WordPress.org Plugin Page' link - https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/wporg-gp-plugin-directory/inc/cli/class-set-plugin-project.php#L80
*same file there's a replace which would need to be amended too - https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/wporg-gp-plugin-directory/inc/cli/class-set-plugin-project.php#L70

'WordPress.org Theme Page' link - https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/wporg-gp-theme-directory/inc/cli/class-set-theme-project.php#L190

Hope that helps clarify. I do feel this would be helpful for translators as they'll be able to go from translating the readme to checking the associated project page for their locale.
Cheers

#2 @ocean90
7 months ago

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Glotpress: Change or add to link to localized theme/plugin page from theme/plugin translation thee/plugin page to Change or add to link to localized theme/plugin page from theme/plugin translation thee/plugin page

Duplicate of #2768.

Note: See TracTickets for help on using tickets.