WordPress.org

Making WordPress.org

Opened 6 months ago

Closed 6 months ago

#4016 closed enhancement (duplicate)

Allow plugins and themes to specify an external URL for the "Development" section

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

Many plugins and themes are developed on an external code and project management platform, commonly GitHub. It would be great if there was a mechanism for developers to specify this URL so it appears on the "Development" tab for plugins, and the "Development" sidebar section for themes.

This way, end users can actually get to a relevant development URL instead of Trac and the SVN repo.

To avoid a new field in the readme or header, this could be added as an option when managing the plugin or theme on wordpress.org.

Change History (4)

#1 @Ipstenu
6 months ago

To avoid a new field in the readme or header, this could be added as an option when managing the plugin or theme on wordpress.org.

We don't have a way to do that that isn't me/Otto editing the posts for the plugins at the moment. That's a ways out.

I personally remain unconvinced we need this. Even on the advanced tab, is this really something the majority of plugins need/want? Users don't need to generally concern themselves with dev, and those who do have looked at the code and can read the headers in the files about where GitHub is.

So the question is "Who is this for?" Is this something you feel is for the majority of users visiting WordPress.org to find a plugin? Or is this for a smaller slice of the developer community?

In addition, it's one more URL we'd have to look out for. Because yes, Devs will put in porn links :/ Again.

#2 @dd32
6 months ago

Personally I'm actually a +1 for this, as I often have to google to figure out where a plugins main development occurs. I'd love there to be a handy This plugin is primarily developed on _Github at dd32/my-plugin_ link.

I would even be happy with it being locked down to a whitelisted set of domains of code providers we recognise as legitimate (and if someone wants to use a different one, they can Meta patch it..) to avoid the spammy repercussions of random links.
It would likely also aid in plugin review as then you can see exactly what the change history is for some plugin where each commit is hundreds of changes rolled into one.

#3 follow-up: @SergeyBiryukov
6 months ago

Duplicate of #3937?

Related: #644, #3880.

#4 in reply to: ↑ 3 @dd32
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to SergeyBiryukov:

Duplicate of #3937?

Related: #644, #3880.

Yup :) I thought I'd seen it recently and commented... #3984 too

Note: See TracTickets for help on using tickets.