WordPress.org

Making WordPress.org

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#4100 closed defect (invalid)

readme parser renders \( as (

Reported by: paulschreiber Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

The wordpress.org readme parser is stripping backslashes / treating them as escape characters.

example text:

Additionally, you can use native mathjax syntax -- $$E=mc^2$$ or \(E=mc^2\).

this is rendered as:

Additionally, you can use native mathjax syntax -- $$E=mc^2$$ or (E=mc^2). 

Sample URL:
https://github.com/phillord/mathjax-latex

Change History (4)

#1 @afragen
13 months ago

You should probably surround the code examples with backticks so it will render as expected. Just as you did in the above description.

#2 @Otto42
13 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug. The readme.txt parser is using markdown. Backslashing parentheses is necessary, because otherwise they would be treated as a link.

[WordPress](https://wordpress.org)

That is valid markdown to make a link, and works in the readme.txt parser. Backslashing the parenths will prevent it from making that link.

If you need to use actual backslashes in markdown, you escape them. So
\\ would produce a \.

Last edited 13 months ago by Otto42 (previous) (diff)

#3 @Otto42
13 months ago

For reference, markdown treats these characters as special, and thus a single backslash can be used to escape them.

\ backslash
` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
Note: See TracTickets for help on using tickets.