WordPress.org

Making WordPress.org

Opened 16 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#4113 closed defect (fixed)

Proposal to change the headings hierarchy in the Themes section

Reported by: afercia Owned by: dd32
Milestone: Priority: normal
Component: Theme Directory Keywords: headings-hierarchy has-patch
Cc:

Description

Splitting this out from #4110.

The headings hierarchy in the Themes section has room for improvements for better SEO and accessibility:

http://cldup.com/zPgm_dVQ8r.jpeg

As mentioned in #4112 the logo shouldn't be a h1. The main topic in this section is "Themes" so the candidate for the main h1 is "Theme Directory" or, maybe better, this section should use the same design used for the Plugin section.

All the themes use a h3 heading so one level is skipped. Instead of bumping them up by one level, I'd suggest to add a h2 before the themes list. Worth noting in the theme details page, there's already a link-back that says "Return to Themes List". I'd suggest to add a "Themes List" h2 before the themes list.

In the theme details page, "Theme Directory" is the main h1:

http://cldup.com/DYGjLmLxdE.png

This is inconsistent with the Plugins section, where the plugin name is the main h1. Suggested: make the Theme's name the main h1, as the Theme is the detail page main topic.

"Commercial Themes" section:
"Commercially Supported GPL Themes" should be the only h1 in the page. All the themes listed there use a h3. Suggested: add a "Themes List" h2 before the themes list.

"Upload Your Theme" section:
"Getting Started" should should be the only h1 in the page. However, this title doesn't tell users what to get started with. Suggested: change the title to make clear it's about getting started with uploading your theme on the WordPress theme directory.

Upload theme page:

http://cldup.com/-LFhHGF211.png

"Submit Your Theme ..." should be the only h1 in the page. The other headings should be bumped up to h2.

Please consider going through all the pages in this section is out of the scope of this ticket. However, these are general guidelines that should be applied everywhere.

Attachments (2)

4113-1.patch (300.1 KB) - added by poena 3 months ago.
update_getting_started.diff (784 bytes) - added by dufresnesteven 6 weeks ago.
Changes h2 to h1 for themes/getting-started.

Download all attachments as: .zip

Change History (9)

#1 @dd32
16 months ago

  • Component changed from General to Theme Directory

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


4 months ago

#3 @poena
4 months ago

Hi

I am also thinking that on the theme details page, the theme author should not be a heading at all.

@poena
3 months ago

#4 @poena
3 months ago

  • Keywords has-patch added

#5 @poena
3 months ago

4113-1 does not solve the duplicate H1's caused by the logo.
I think https://meta.trac.wordpress.org/ticket/4110 needs to be solved first.

@dufresnesteven
6 weeks ago

Changes h2 to h1 for themes/getting-started.

#6 @dd32
6 weeks ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 9725:

Theme Directory: Use better heading numbers for the Theme Directory.

Props afercia, poena, dufresnesteven, dd32.
Fixes #4113.
See #4110.

#7 @dd32
6 weeks ago

In 9726:

Theme Directory: Bring over the Plugin Directory style header, providing a better intro to the Theme Directory.

Props poena.
See #4113.
Fixes #4924.

Note: See TracTickets for help on using tickets.