WordPress.org

Making WordPress.org

Opened 5 months ago

Closed 5 months ago

#4152 closed enhancement (duplicate)

Change screenshots and FAQ redirects to a 301

Reported by: joostdevalk Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: seo
Cc:

Description (last modified by joostdevalk)

When we rebuilt the plugin directory, we redirected several types of URLs to the main plugin page adding the subpage as a fragment:

  • /screenshots/ became #screenshots
  • /faq/ became #faq
  • /installation/ became #installation
  • /other_notes/ became #other_notes
  • /developers/ became #developers

These all work for the user, but it would be very cool if we could change that 302 redirect to a 301.

It would be _even_ better if we could decide whether to add that fragment identifier based on the fact that that tab actually exists for that particular plugin.

Change History (4)

#1 @joostdevalk
5 months ago

  • Description modified (diff)
  • Summary changed from Change screenshots redirect to a 301 to Change screenshots and FAQ redirects to a 301

#2 @joostdevalk
5 months ago

  • Description modified (diff)

#3 @SergeyBiryukov
5 months ago

Duplicate of #4026? :)

#4 @dd32
5 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Lets close this as a duplicate of #4026 to keep the discussion in one place.

Note: See TracTickets for help on using tickets.