WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#4266 closed defect (invalid)

Invalid on-screen error message when publishing a post

Reported by: kartiks16 Owned by:
Milestone: Priority: normal
Component: HelpHub Keywords: has-screenshots needs-patch
Cc:

Description

Issue Description
When I am publishing a drafted version post, on screen message is coming up which says Publishing failed (screenshot attached). But the error message is wrong because the draft is actually getting published.

https://user-images.githubusercontent.com/11072678/51828569-dc5cdb80-2311-11e9-898d-522e530e212b.png

Context
Without getting back to the post list it is not possible to know what exactly happened.

Steps to reproduce:
Edit a post
Click on Publish > Publish
Expected Result:
Error message should not appear when post is actually Published

Actual Result:
Error message is appearing even the post got published

Attachments (1)

Error-ScreenShot.png (67.4 KB) - added by kartiks16 3 months ago.
Error

Download all attachments as: .zip

Change History (10)

@kartiks16
3 months ago

Error

#1 @Otto42
3 months ago

  • Resolution set to invalid
  • Status changed from new to closed

The meta trac is for tracking issues and fixes for the WordPress.org properties like the website, not for handling problems with the WordPress software itself.

If you have issues, you should post in the WordPress.org Support forums: https://wordpress.org/support/forums

#2 @kartiks16
3 months ago

Hello @Otto42

During our weekly meeting that took place on 11th March. We discussed moving the Github Helphub issues to Meta trac and adding the component as "Helphub".

Can you please discuss the same once with @zzap ?

Also after adding here, I have requested @zzap to review it once and if I have made a mistake she can guide me so I can rectify?

Let me know your thoughts on this.

Thanks.

#3 @Otto42
3 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Ok, I'm confused. I thought you were making a post about your own site, but the screenshot shows WordPress.org.

So, the problem needs to be described better. If it's an issue on the site, then the issue is unclear.

What is the actual problem on wordpress.org, and why do you have a screenshot of you trying to publish an already published post from 2 months ago? You should not have a "Publish" button, but an "Update" button instead.

Basically, if there's an issue on WordPress.org, please describe it in more detail.

#4 follow-up: @kartiks16
3 months ago

@Otto42

Sorry for the confusion. I think @zzap is the best person to clear the confusion.

Basically I don't have any problem or issue, I am just contributing by moving GitHub Helphub issue to Meta trac, as per guidelines giving during weekly #docs meeting.

This issue has been raised by someone else in GitHub.

Thanks.

#5 in reply to: ↑ 4 @subrataemfluence
3 months ago

As far I remember it was opened by me.
Replying to kartiks16:

@Otto42

Sorry for the confusion. I think @zzap is the best person to clear the confusion.

Basically I don't have any problem or issue, I am just contributing by moving GitHub Helphub issue to Meta trac, as per guidelines giving during weekly #docs meeting.

This issue has been raised by someone else in GitHub.

Thanks.

#6 follow-ups: @Otto42
3 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Okay, let's not move issues from where they originally were to here unless they are reproducible.

https://github.com/WordPress/HelpHub/issues/284

If there is a current issue with the site, then yes, open a ticket about it. But reposting something as new, by a completely different person, months afterwards, is just confusing.

#7 in reply to: ↑ 6 @subrataemfluence
3 months ago

I agree with you. However, this is a persisting issue although might not be reproduced all the time.

Replying to Otto42:

Okay, let's not move issues from where they originally were to here unless they are reproducible.

https://github.com/WordPress/HelpHub/issues/284

If there is a current issue with the site, then yes, open a ticket about it. But reposting something as new, by a completely different person, months afterwards, is just confusing.

#8 in reply to: ↑ 6 @milana_cap
3 months ago

Replying to Otto42:

Okay, let's not move issues from where they originally were to here unless they are reproducible.

https://github.com/WordPress/HelpHub/issues/284

If there is a current issue with the site, then yes, open a ticket about it. But reposting something as new, by a completely different person, months afterwards, is just confusing.

Hi @Otto42,

Thank you for your comment. This is the effort of moving all HelpHub Phase 1.5 issues from Github to Trac in order to move on with development.

I do agree with opening tickets only for issues that can be reproduced at wp.org. Not pointing this out before we started with migration is my mistake. Sorry about that.

We will do the tests and reopen ticket with detailed explanation if issue appear again.

Sorry once again for the confusion. Thank you.

This ticket was mentioned in Slack in #docs by zzap. View the logs.


3 months ago

Note: See TracTickets for help on using tickets.