WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#427 closed defect (wontfix)

Erroneous "Email Address already in use" error when attempting to update profile

Reported by: johnbillion Owned by:
Milestone: Priority: high
Component: Profiles Keywords:
Cc:

Description

Steps to reproduce:

  1. Visit https://wordpress.org/support/profile/ and click the "Edit" link
  2. Change a field (such as your password) and click "Update Profile"
  3. Note that the page returns an "Address already in use" error next to the Email field and your profile is not updated

Change History (6)

#1 @Otto42
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This happens to you because you have three different accounts all with the same email address, which we no longer allow.

I've changed the email on the other two account that you're not using.

The message is not incorrect, just odd for that time and place. Your email address was already in use, on other accounts.

#2 @nacin
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

It might be good for us to fix this message so people can actually separate all of their accounts. We could warn that X other accounts are using this email and they must change X-1 of them.

#3 @Otto42
5 years ago

Seems a bit edge-casey, since we no longer allow accounts to be made re-using emails like this. All accounts that are still this way are what, 5+ years old?

Additionally, long term, the support/profiles page will go away in favor of the new profiles page.

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


4 years ago

#5 @samuelsidler
4 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

This is edge-case enough that we shouldn't worry about it.

#6 @Otto42
4 years ago

For anybody who has this problem and finds this ticket, email forum-password-resets at wordpress org and the team there can assist in correcting the problem for you.

Note: See TracTickets for help on using tickets.