WordPress.org

Making WordPress.org

Opened 18 months ago

Closed 5 months ago

#4331 closed defect (fixed)

News archive templates should use canonical URL tags

Reported by: jonoaldersonwp Owned by: dd32
Milestone: Priority: high
Component: General Keywords: seo analytics
Cc:

Description

Individual news articles (like https://wordpress.org/news/2019/01/wordpress-5-0-3-maintenance-release/) correctly use canonical URL tags.

However, archives / the homepage / categories do not.

E.g., https://wordpress.org/news/, https://wordpress.org/news/page/2/, https://wordpress.org/news/category/testing/ should all have/use canonical URL tags.

Change History (8)

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


16 months ago

#2 @dd32
16 months ago

  • Keywords changed from seo, analytics to seo analytics
  • Owner set to dd32
  • Status changed from new to accepted

#4 @jonoaldersonwp
7 months ago

Given that:

  • The upstream ticket has been dead for years, and;
  • The problem is well-defined and constrained, and;
  • It's hurting our performance, brand and reach with every day which goes by, then;

Can we please just fix this locally?

#5 @jonoaldersonwp
5 months ago

This is causing serious problems with our SEO and our analytics. Can we fix it locally, please?

#6 @jonoaldersonwp
5 months ago

This is actively harming the reach and effectiveness of content in the news section.
What needs to happen to escalate a fix for this?

#8 @coffee2code
5 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [16005-dotorg]:

News blog: Output <link rel="canonical"> tag for home page and category/tag/taxonomy archives.`

Note: See TracTickets for help on using tickets.