WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#4333 closed defect (fixed)

Forum support profile pages should canonise to the profiles subdomain version

Reported by: jonoaldersonwp Owned by: coffee2code
Milestone: Priority: low
Component: Support Forums Keywords: seo
Cc:

Change History (9)

#1 @coffee2code
3 months ago

  • Keywords reporter-feedback added

Wouldn't doing this be inaccurate?

The support forum profile (e.g. https://wordpress.org/support/profile/jonoaldersonwp) is not considered by us to be equivalent to the WP.org profile (e.g. https://profiles.wordpress.org/jonoaldersonwp/). The former is very much support forum focused, uniquely listing the topics, replies, and reviews written by the user, favorited topics, as well as counts of their total topics, replies, and reviews. The latter of course offers the WP.org-wide view of things for the user, including activities, badges, plugins, themes, favorites, social media, bio, and more.

There is overlap in information presented on both, but that's rather minimal -- just the user's full name, username, Slack handle, and Gravatar image. We do hope to eventually unify both profiles (#518), but in the meantime I don't think it's fair to suggest equivalency or preference since they differ in intent. And other than the basic user info, both profiles won't have duplicate content.

#2 @jonoaldersonwp
3 months ago

Yes, agreed. These aren't close enough for a canonical to be effective.
The problem isn't so much duplicate content, but duplicate focus/intent. We have lots of different 'profiles' for a given user, when we should just have one.

Given that we're gradually working towards consolidating these, let's just noindex this version for now, instead of using a canonical? :)

#3 @dd32
3 months ago

  • Keywords reporter-feedback removed

Just noting that https://wordpress.org/support/profile/jonoaldersonwp is bbPress 1.x, which is currently slated for removal.

#4 @jonoaldersonwp
3 months ago

What does 'removal' mean? As in, 1.x is deprecated and needs updating/replacing, or, we're going to bin these profile pages?

If we're planning on removing, we'll need a redirection plan.

#5 @ocean90
3 months ago

They will be removed just like #4135.

Only https://wordpress.org/support/users/jonoaldersonwp and https://profiles.wordpress.org/jonoaldersonwp are valid profile pages. Anything on wordpress.org/support/profile/* doesn't even show any new data since two years.

#6 @jonoaldersonwp
3 months ago

Ok, so, let's 301 redirect https://wordpress.org/support/profile/(.*) to https://profiles.wordpress.org/$1.

Then

#7 @coffee2code
3 months ago

  • Owner set to coffee2code
  • Status changed from new to accepted

#8 @coffee2code
3 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [dotorg-14980] though to a different target for the redirect.

In my original response to this thread I didn't realize you were referring to the bbPress 1.x forums since I already had this redirect in place for myself from earlier. But my explanation provided there still holds: the forums profile and the w.org profile are currently two different profiles (until they eventually get unified). In the meantime, the new forum profile is more the current equivalent for the old forum profile than the w.org profile. As such, I've redirected the old forum profile to the new forum profile.

Note: See TracTickets for help on using tickets.