WordPress.org

Making WordPress.org

Opened 13 months ago

Closed 4 months ago

Last modified 4 months ago

#4413 closed defect (fixed)

Pagination components shouldn't link to 'page 1' state

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: low
Component: Support Forums Keywords: seo
Cc:

Description

On templates like https://wordpress.org/support/view/support-forum-no/page/2/, the link to the first page in the pagination component links to /page/1/. This should instead link to the series root.

Change History (5)

#1 @dd32
12 months ago

Ultimately caused by WordPress's paginate_links() function returning /page/1/ links, and bbPress doing a very bland attempt at working around this in https://bbpress.trac.wordpress.org/browser/branches/2.5/includes/topics/template.php?marks=409#L405 by only replacing /page/1/' with '.. but core uses /page/1/" for some links.

This is fixed in bbPress 2.6 with bbp_paginate_links() I believe, which we should probably look at moving to instead.

edit: If moving to 2.6 doesn't pan out, a str_replace on the paginate_links function will probably also achieve this.

Last edited 12 months ago by dd32 (previous) (diff)

#2 @johnjamesjacoby
7 months ago

As @dd32 mentioned, this is indeed fixed upstream already in bbPress 2.6. 👍

This ticket was mentioned in Slack in #forums by clorith. View the logs.


4 months ago

#4 @Clorith
4 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This has indeed been resolved at this time.

Note: See TracTickets for help on using tickets.