WordPress.org

Making WordPress.org

Opened 4 months ago

Closed 4 months ago

#4483 closed defect (fixed)

Improper query alterations causing PHP warnings and errors

Reported by: dd32 Owned by: dd32
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Currently accessing a URL such as /plugins/plugin-name/?author=123 will cause a PHP warning and ultimately cause the page to not-redirect as intended.

It looks like this is being caused by some bad logic in the query alterations code, the Plugin Directory thinks it's an Author Archive query, but Core disagrees.

Change History (1)

#1 @dd32
4 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 8894:

Plugin Directory: Limit the author archive query alteration code to when an Author archive query is detected by WP_Query.

This should solve a case where a singular request with author query vars causes a PHP fatal error.

Fixes #4483.

Note: See TracTickets for help on using tickets.