WordPress.org

Making WordPress.org

Opened 3 weeks ago

Closed 3 weeks ago

#4640 closed defect (duplicate)

Comments URL fragment identifier points to non existing page fragment

Reported by: afercia Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: has-screenshots
Cc:

Description

In the Make posts emails, at the end of the email there's a link to "See all comments", for example:

http://cldup.com/0NLkCWRw9S.png

this link points to a #comments page fragment, for example:

https://make.wordpress.org/updates/2019/07/30/update-sanctions-and-open-source/#comments

However, in the page there's no element with a comments ID to serve as page fragment identifier, so the link doesn't work at all.

Either an ID should be added in a proper place in the comments section, or the link should be removed from the email template.

Change History (4)

#1 @Otto42
3 weeks ago

An id="comments" should be added to <div class="o2-post-comments"></div> in the o2 plugin, in /inc/tpl/post-view.php.

Ping to whomever maintains o2 in https://github.com/Automattic/o2/trunk.

#3 @joyously
3 weeks ago

Duplicate of #4403

#4 @SergeyBiryukov
3 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4403.

Note: See TracTickets for help on using tickets.