WordPress.org

Making WordPress.org

#4651 closed defect (fixed)

Invalid themes requests should redirect/404

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: high
Component: Theme Directory Keywords: seo analytics reporter-feedback
Cc:

Description

A request to https://wordpress.org/themes/?p=5 returns a 404 error, but, then the JS kicks in and returns the themes front page.

This is incredibly messy from an SEO and from an analytics perspective.

We either need to:

  • Continue to let 404 these 'properly' server-side, but replicate this experience client-side (which is odd, as adding an arbitrary query parameter like this shouldn't result in a 404), or;
  • Ensure that the server-side request matches the client-side experience.

Change History (3)

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


13 months ago

#2 @tellyworth
12 months ago

  • Keywords reporter-feedback added

I can't reproduce this, is it still an issue? It may have been fixed by something else.

#3 @jonoaldersonwp
12 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Wooho!

Note: See TracTickets for help on using tickets.