WordPress.org

Making WordPress.org

Opened 8 weeks ago

Closed 8 weeks ago

Last modified 8 weeks ago

#4736 closed defect (invalid)

Plugin review submitted without star ratings

Reported by: anand.au14 Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

On one of my plugin "Form Vibes" I received a review. It was full of praises so you can expect a 5 Star Rating.
But strange thing is that there was no rating at all.

Also it is displaying Total Review count as 7 while in the list under it, it is displaying all 8 review.
So it is also skipping this faulty review in counting total review.

Here is the link to the review
https://wordpress.org/support/topic/works-as-advertised-614/

I have already requested to update the review, so it might show you some star rating later on.
I have attached the screenshot of the current state.

Attachments (2)

review-list-wrong-count.png (357.6 KB) - added by anand.au14 8 weeks ago.
Wrong review count at the top. Displaying count as 7 while there are 8 review listed below
review-without-star-rating.png (83.5 KB) - added by anand.au14 8 weeks ago.
Review without star rating.

Download all attachments as: .zip

Change History (5)

@anand.au14
8 weeks ago

Wrong review count at the top. Displaying count as 7 while there are 8 review listed below

@anand.au14
8 weeks ago

Review without star rating.

#1 @Otto42
8 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed

Looks like the user updated it to 4 stars.

#2 @anand.au14
8 weeks ago

Hi @Otto42

Yes user did updated the rating to 4 star. I am not concern about rating on my plugin.
What I am referring here is a possible bug that plugin/theme can be submitted without a star rating.

Review form doesn't allow you to submit a review with less than 1 star. So if such reviews are getting submitted then there is surely some missing validation on backend.

#3 @dd32
8 weeks ago

  • Component changed from Plugin Directory to Support Forums

I suspect this was probably caused by #4275 or something similar to it.

Note: See TracTickets for help on using tickets.