WordPress.org

Making WordPress.org

Opened 2 weeks ago

Closed 8 days ago

Last modified 8 days ago

#4754 closed defect (duplicate)

Noindex profile pages which don't have any 'Activity' content

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: high
Component: Profiles Keywords: seo
Cc:

Description (last modified by jonoaldersonwp)

Hiding profiles without 'Activity' content from search engines is part of a broader approach to 'solving' spam profiles on wordpress.org. See https://www.jonoalderson.com/wordpress/wordpress-org-toxic-profile-spam/ for long-form research and rationale.

Specifically, we should add a meta robots tag with a noindex, follow value to any profile which has no 'Activity' content (and to any associated profile pages; e.g., in the https://wordpress.org/support/users/ section).

Change History (7)

#1 @jonoaldersonwp
2 weeks ago

  • Description modified (diff)

#2 follow-up: @tellyworth
9 days ago

  • Keywords reporter-feedback added

The description here doesn't seem to match the title, was this supposed to be two separate tickets?

#3 in reply to: ↑ 2 ; follow-up: @jonoaldersonwp
9 days ago

  • Summary changed from Add recaptcha to 'edit profile' pages to Noindex profile pages which don't have any 'Activity' content

Replying to tellyworth:

The description here doesn't seem to match the title, was this supposed to be two separate tickets?

Oops. There is indeed a different ticket for that. Updating now.

#4 in reply to: ↑ 3 @dd32
8 days ago

  • Resolution set to duplicate
  • Status changed from new to closed

Feel free to create a recaptcha-on-profiles ticket.

At that point though, I think it's too late and we should consider other options (Akismet, etc)

This is now a duplicate of #4714 AFAICT

#5 @jonoaldersonwp
8 days ago

  • Keywords reporter-feedback removed
  • Resolution duplicate deleted
  • Status changed from closed to reopened

This isn't a duplicate; "No activity" is subtly different from "no content". This also captures the 'sibling' profile pages, which the other ticket doesn't. Therefore I'm re-opening this one, and closing the other.

I'll be adding a separate ticket for recaptcha on profile edit screens shortly, as per my post :)

#6 @dd32
8 days ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

You're making it more complicated than it is.

Marking as a duplicate of #4714.

#7 @dd32
8 days ago

In 9170:

Support Forums: Add a robots header for banned users and those who don't have any profile content.

See #4754, #4632, #4714, #4696.

Note: See TracTickets for help on using tickets.