WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 3 years ago

#483 closed defect (duplicate)

Mixed content warnings on theme pages cause preview to redirect to new page

Reported by: tollmanz Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

On theme pages, screenshots should be clickable, which cause thickbox to load with a theme preview. This is broken due to the necessary assets that control this behavior being blocked in Chrome due to being served via HTTP instead of HTTPS.

To reproduce:

  1. Open a theme page in Chrome (e.g., https://wordpress.org/themes/make)
  2. Open Dev Tools
  3. Open the Console
  4. Notice the following warning:
[blocked] The page at 'https://wordpress.org/themes/make' was loaded over HTTPS, but ran insecure content from 'http://wordpress.org/bb-theme/themes/thickbox/thickbox.css': this content should also be loaded over HTTPS.
 make:1
[blocked] The page at 'https://wordpress.org/themes/make' was loaded over HTTPS, but ran insecure content from 'http://wordpress.org/bb-theme/themes/thickbox/thickbox.js': this content should also be loaded over HTTPS.
 make:1
[blocked] The page at 'https://wordpress.org/themes/make' was loaded over HTTPS, but ran insecure content from 'http://wordpress.org/bb-theme/themes/thickbox/theme-preview.js': this content should also be loaded over HTTPS.
  1. Click the screenshot
  2. Notice the preview opens in a new page instead of in the thickbox

Change History (4)

#1 @Otto42
4 years ago

This is caused by a redirection issue from when we moved the theme around.

It can be fixed, but doing so breaks the preview frame because the wp-themes.com domain (where we have the previewer) has an incorrect SSL certificate. We'll need to fix that before fixing this.

This ticket was mentioned in IRC in #wordpress-meta by sams. View the logs.


4 years ago

#3 @Otto42
4 years ago

Related: #344

#4 @Otto42
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #344.

Note: See TracTickets for help on using tickets.