WordPress.org

Making WordPress.org

Opened 16 months ago

Closed 5 months ago

#4904 closed enhancement (reported-upstream)

Allow moderators to reply to archived or spam topics

Reported by: sterndata Owned by: SergeyBiryukov
Milestone: Priority: normal
Component: Support Forums Keywords: has-patch
Cc:

Description

Now that one can use an @name to send mail even if it the "name"'s post has been marked as spam or archived, it would be nice to be able to reply to the post. When the first post in a topic has been marked as spam or archived, moderators are not permitted to reply.

Attachments (1)

4904.diff (1.5 KB) - added by valentinbora 15 months ago.
Allow moderators to reply to closed topics through the bbp_current_user_can_access_create_reply_form filter

Download all attachments as: .zip

Change History (10)

#1 @sterndata
16 months ago

This also applies if a post is "pending".

This ticket was mentioned in Slack in #forums by sterndata. View the logs.


16 months ago

#3 @dd32
16 months ago

This looks like a bbPress bug - I've opened https://bbpress.trac.wordpress.org/ticket/3309

The capability checks seem to be basing the reply form off whether or not the current user can edit the reply but there's no reply object so it's false, even though the mod can edit the topic.

If it's not-a-bug in bbPress, we can probably make this happen through the bbp_current_user_can_access_create_reply_form filter, although there might be more places that need changing.

@valentinbora
15 months ago

Allow moderators to reply to closed topics through the bbp_current_user_can_access_create_reply_form filter

#4 @valentinbora
15 months ago

  • Keywords has-patch added

This ticket was mentioned in Slack in #forums by valentinbora. View the logs.


15 months ago

#6 @SergeyBiryukov
15 months ago

  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#7 @dd32
15 months ago

I'd prefer to see this fixed in bbPress core, or it be confirmed that it's not a bbPress bug before we patch it on the W.org side.

#8 @valentinbora
15 months ago

  • Keywords blocked-upstream added

#9 @dd32
5 months ago

  • Keywords blocked-upstream removed
  • Resolution set to reported-upstream
  • Status changed from reviewing to closed

Fixed upstream, should be deployed to WordPress.org.

Note: See TracTickets for help on using tickets.