Making WordPress.org

Opened 4 years ago

Closed 3 weeks ago

#4977 closed enhancement (duplicate)

Add plugin closed message to plugins_api.

Reported by: ronalfy's profile ronalfy Owned by:
Milestone: Priority: normal
Component: API Keywords:
Cc:

Description

Currently, the return is a WP_Error, which is fine. However, the message displays that the plugin could not be found. With our use-case, we're trying to distinguish between third-party plugins and .org plugins. Ideally, the message would be contextual.

I suggest that there are two WP_Error objects we can expect from the API. One if the plugin is missing (and it truly doesn't exist) and one if the plugin has been closed (meaning, it exists, but is closed).

This would benefit our use-case, and I imagine other plugins that need to check programmatically if a plugin has been removed from the repo.

Change History (2)

#1 @rafiahmedd
2 years ago

Is there any plan to implement this?

#2 @dd32
3 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

It's a newer ticket, but I'm marking this as a duplicate of #7057 due to more discussion on that one.

Note: See TracTickets for help on using tickets.