WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 4 years ago

#504 closed defect (invalid)

"Mark as duplicate of #" appears twice in Batch Modify

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

See the screenshot.

Attachments (1)

meta-504.png (39.3 KB) - added by SergeyBiryukov 5 years ago.

Download all attachments as: .zip

Change History (5)

This ticket was mentioned in IRC in #wordpress-meta by sams. View the logs.


5 years ago

#2 @SergeyBiryukov
5 years ago

This only happens on a custom report that includes closed tickets.

Per IRC discussion, filed upstream: http://trac.edgewall.org/ticket/11647.

#3 @SergeyBiryukov
5 years ago

These are actually two different actions:

The batch modify UI shows all the workflow actions that can be applied to some shown tickets. If the shown tickets are in different states (open, closed etc.), different sets of actions may be applicable to different tickets. In your case, for the open tickets the action duplicate.name = mark as duplicate of # is shown, and for the closed tickets the action change_to_duplicate.name = mark as duplicate of # is shown. They look the same (because you configured them to look the same) but these are two different actions.

We could probably make the second instance change_to_duplicate.name = change to duplicate of #.

#4 @nacin
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Yeah, I could have told you this was because of our configuration. :)

I'm not inclined to bother changing this. Also, Batch Modify is only available to gardeners and should use very sparingly anyway, and probably not for marking things as duplicates. (I'm not even sure the duplicates plugin is compatible with batch modification.)

Note: See TracTickets for help on using tickets.