WordPress.org

Making WordPress.org

Opened 14 months ago

Closed 13 months ago

Last modified 13 months ago

#5060 closed defect (fixed)

Component page is only listing one or two components

Reported by: garrett-eclipse Owned by:
Milestone: Priority: high
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

Currently the components page is missing most of the components and only listing one or two at a time;
https://make.wordpress.org/core/components/

Attachments (1)

Screen Shot 2020-02-26 at 2.42.21 PM.png (94.1 KB) - added by garrett-eclipse 14 months ago.
Component page only showing 2 components

Download all attachments as: .zip

Change History (12)

@garrett-eclipse
14 months ago

Component page only showing 2 components

This ticket was mentioned in Slack in #core by garrett-eclipse. View the logs.


14 months ago

#3 @SergeyBiryukov
14 months ago

Tracked this down to "Too Many Requests" from wp_remote_post() to https://core.trac.wordpress.org/wpapi?call=get_component_history in plugins/trac-notifications/trac-notifications-http-client.php:

HTTP/1.1 429 Too Many Requests
Server: nginx
Date: Thu, 27 Feb 2020 00:41:52 GMT
Content-Type: text/html
Content-Length: 162
Connection: close

This will probably require Systems to fix.

This ticket was mentioned in Slack in #meta by dd32. View the logs.


14 months ago

This ticket was mentioned in Slack in #accessibility by sergey. View the logs.


14 months ago

#6 @dd32
14 months ago

#5074 was marked as a duplicate.

#7 @dd32
14 months ago

Just noting that systems is aware of the issue, and the cause.

In short - Make P2s were causing significant load issues on Trac causing outages, due to the way the Components pages and the P2 hovercards interact with Trac.

This ticket was mentioned in Slack in #meta by dd32. View the logs.


14 months ago

#9 @SergeyBiryukov
13 months ago

Just noting this also affects the ticket notifications area, which is no longer displayed.

Make sure %s receives a warm welcome. It's their first ticket! message was in that area and is also not displayed now, which makes it harder to triage tickets properly.

Last edited 13 months ago by SergeyBiryukov (previous) (diff)

#10 @dd32
13 months ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

This should now be resolved thanks to systems.

This ticket was mentioned in Slack in #meta by whyisjake. View the logs.


13 months ago

Note: See TracTickets for help on using tickets.