WordPress.org

Making WordPress.org

Opened 2 months ago

Closed 2 months ago

#5139 closed defect (duplicate)

Please add plugin author replies to the plugin's review page

Reported by: wpt00ls Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Plugin reviews pages, for example https://wordpress.org/plugins/wordpress-seo/#reviews only shows reviews from the users. The replies from the plugin author isn't shown. In cases of bad reviews, sometimes the end user is baseless, ill-aware, biased or sponsored. The plugin authors reply doesn't show up on this listening page (it shows up when you click on the review link). It may sometime feel like a boxing match where the plugin's hands are tied.

I request you to add replies from plugin authors on the listing page.

Tripadvisor/google reviews and many others do this. I am attaching a screenshot from tripadvisor.

Attachments (1)

trip-advisor.png (315.3 KB) - added by wpt00ls 2 months ago.
Sample review listing page on tripadvisor which shows replies from owners

Download all attachments as: .zip

Change History (4)

@wpt00ls
2 months ago

Sample review listing page on tripadvisor which shows replies from owners

#1 @carike
2 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hallo there :)

Welcome to Meta Trac.

The plugin author already does have the ability to respond to reviews for their plugin.
If you don't see a response, it is for one of three reasons:

  • The plugin author chose not to respond;
  • The plugin author's post is currently awaiting moderation (because they previously did something that is against the forum's guidelines like asking for admin access to someone's site and a moderator needs to check all their posts before it goes live);
  • The plugin author's post was removed because it violated the forum guidelines (for example, it contained personal information about the poster, or it contained excessive swearing, or something similar).

In the overwhelming majority of cases, when a reply isn't shown, it is because of reason number 1, namely that the author(s) chose not to respond. This is their choice. We cannot (and should not) force them to.

All the best :)

#2 @carike
2 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Edited:
I see you mean you believe the plugin author's response should be shown on the summary page, so deleting the resolution.

#3 @Otto42
2 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #1805.

Note: See TracTickets for help on using tickets.