WordPress.org

Making WordPress.org

Opened 7 weeks ago

Closed 7 weeks ago

#5145 closed enhancement (duplicate)

Standardize links to external repos for plugins and themes

Reported by: stevegrunwell Owned by:
Milestone: Priority: low
Component: Plugin Directory Keywords:
Cc:

Description

As a plugin author, I usually make a point of adding a link to plugins' external repositories in their readme.txt files.

Meanwhile, when I want to submit changes to a plugin, the readme.txt file is the first place I check, before doing a search for "<plugin name> GitHub".

Considering the plugin developer FAQ explicitly states that the SVN repo is *not* for code versioning, might it be helpful to add an [optional] "Contributing" header to the readme.txt standard to help drive open-source contributions to plugins?

In practice, it might look something like this:

<?php
/**
 * Plugin Name:       My Basics Plugin
 * Plugin URI:        https://example.com/plugins/the-basics/
 * Description:       Handle the basics with this plugin.
 * Version:           1.10.3
 * Requires at least: 5.2
 * Requires PHP:      7.2
 * Author:            John Smith
 * Author URI:        https://author.example.com/
 * License:           GPL v2 or later
 * License URI:       https://www.gnu.org/licenses/gpl-2.0.html
 * Text Domain:       my-basics-plugin
 * Domain Path:       /languages
 * Contributing:      https://github.com/johnsmith/my-basics-plugin
 */

The link provided by the developer could then be displayed on the "Development" tab of the WordPress.org plugin page:

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

You may also contribute to the plugin's development here.

Change History (1)

#1 @ocean90
7 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3937.

Note: See TracTickets for help on using tickets.