Making WordPress.org

Opened 4 years ago

Last modified 11 months ago

#5146 reopened defect (bug)

All Recent Topics RSS Feed returns topics from plugins and themes, not the general forums

Reported by: mmediagroup's profile mmediagroup Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

I've just subscribed to the Recent Topics RSS feed in Slack https://wordpress.org/support/topics/feed/ but it only seems to be returning topics created on plugin and theme support pages, and none from the general forum topics.

Change History (9)

#1 @casiepa
4 years ago

You want to subscribe to all topics in all forums?

For one specific forum you could use: https://wordpress.org/support/forum/installation/feed/?type=topic

This ticket was mentioned in Slack in #bbpress by casiepa. View the logs.


4 years ago

#3 @mmediagroup
4 years ago

Hey @casiepa! Ideally, yes - that's the behaviour I'd expect (or at least get all topics in the support forum, not from the plugins and themes). I was told this was unexpected behaviour hence I opened this issue :)

#4 @SergeyBiryukov
4 years ago

  • Component changed from General to Support Forums

#5 @mmediagroup
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Understood! Closing then :)

#6 @dd32
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

re-opening since this shouldn't be happening.

#7 @dd32
4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

As far as I can tell, this is working as expected, however there are a lot of plugin/theme threads created verses other forums.

Caching and the limited number of topics in the feed mean it's entirely possible to miss the non-plugin/theme threads.

#8 @mmediagroup
4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I've tried the following feed https://wordpress.org/support/view/all-topics/feed/ and expect it to return the same posts as seen here https://wordpress.org/support/view/all-topics/, but instead it returns results from all forums (I am seeing posts only from plugins and themes, but you may be right that they are getting lost in the noise).

Interestingly, it seems that https://wordpress.org/support/view/no-replies/feed/ works as expected, and returns posts only from here: https://wordpress.org/support/view/no-replies/

Last edited 4 years ago by mmediagroup (previous) (diff)

This ticket was mentioned in Slack in #forums by thelmachido. View the logs.


11 months ago

Note: See TracTickets for help on using tickets.