WordPress.org

Making WordPress.org

Opened 6 weeks ago

Closed 6 weeks ago

#5167 closed enhancement (duplicate)

Add support for marking content as NSFW

Reported by: Clorith Owned by:
Milestone: Priority: high
Component: Support Forums Keywords: has-patch
Cc:

Description

We've always allowed NSFW content, so long as it conforms to the law, it's perfectly fine, but not everyone is good about adding a note that their content may not be appropriate for all.

This ticket looks to tackle that by introducing both a way to mark topics NSFW when they are created or edited (either by the user them selves, or by a moderator), which will prepend the topic with a [NSFW] tag, and mark the content as noindex to avoid our current conundrum of search engines in part marking us as an adult entertainment site.

Along with this, since we know users may not always remember to check boxes, it introduces a new admin interface under Forums for keymasters to assign mature content keywords.

When a topic is created or edited, and not by a moderator, that list of tags is checked against the topic title, and the URL the user needs help with, and if it is found inside of there (as a case-insensitive wildcard match), the topic is automatically marked as NSFW as well.

Attachments (1)

5167.patch (8.5 KB) - added by Clorith 6 weeks ago.

Download all attachments as: .zip

Change History (3)

@Clorith
6 weeks ago

#1 @dd32
6 weeks ago

This is actually a duplicate of #2018 which also has a patch

#2 @Clorith
6 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2018.

Wow, how did I miss that, I even provided input on it.

I'll move my patch over on that ticket, which would combine Denis' work with this, as mine tackles more items which came up during discussions, but they should definitely get some credit for the initial work there.

Note: See TracTickets for help on using tickets.