Making WordPress.org

Opened 4 years ago

Closed 2 years ago

#5226 closed defect (bug) (worksforme)

"My Favorites" does not work, redirect to "Favorits" tags

Reported by: fahimmurshed's profile fahimmurshed Owned by:
Milestone: Priority: low
Component: Plugin Directory Keywords:
Cc:

Description

On the plugin directory "My Favorites" it shows Favorites tags, not a user Favorites plugins list.

Screenshot: https://prnt.sc/smooir

Change History (7)

#1 follow-up: @Otto42
4 years ago

You have to be logged in for it to direct you to your favorites. If you're not logged in, then it will redirect to searching for "favorites".

https://wordpress.org/plugins/browse/favorites/

#2 follow-up: @fahimmurshed
4 years ago

Thanks for your reply :)

It is not redirecting to my favorites after login or without login. Even on the "Favorites" page that's plugins is not in my fav list https://prnt.sc/smqafi

It makes sense, if not logged in it should be hidden!

Stay safe, Otto.

#3 in reply to: ↑ 1 @felipeloureirosantos
4 years ago

Replying to Otto42:

You have to be logged in for it to direct you to your favorites. If you're not logged in, then it will redirect to searching for "favorites".

I personally see that those things shouldn't be related.

If you aren't logged in, so it should redirect you to the login page, then show your favorites list after logging in.

#4 in reply to: ↑ 2 @felipeloureirosantos
4 years ago

Replying to fahimmurshed:

It is not redirecting to my favorites after login or without login. Even on the "Favorites" page that's plugins is not in my fav list https://prnt.sc/smqafi

I wasn't able to reproduce it. It seems to work just as expected when you're logged in. Could you possibly provide the steps for replication?

I tried the following:

  1. Logged in
  2. Accessed a tag (https://wordpress.org/plugins/tags/gutenberg/)
  3. Clicked "My Favorites" on the navigation menu
  4. I was able to see my favorite plugins there

#5 @dd32
4 years ago

In 9911:

Plugin Directory: The /browse/favorites route should be acessible even if it has no posts.

See #5226.

#6 @dd32
4 years ago

  • Keywords needs-testing removed

This wasn't the intended behaviour, this was a side effect of one of the many seo changes requested.

The redirect here was a 301 too, so the cached by browsers and load balancers, which may have resulted in the page being inaccessible even when logged in.

[9911] has removed the redirect, but the resulting page still needs some work IMHO:

Nothing Found

Login to WordPress.org to mark plugins as favorites.

#7 @fahimmurshed
2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I have logged in and that URL works flawlessly.

Note: See TracTickets for help on using tickets.