WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#523 closed defect (fixed)

Handbook shows all pages with the same slug

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Component: Handbooks Keywords:
Cc:

Description

To be honest, I have no idea how this happened.

https://make.wordpress.org/support/handbook/getting-started/

That page was also showing THIS page:

https://make.wordpress.org/support/handbook/contributing-to-the-wordpress-codex/getting-started/

I noticed they had the same end slug, so I changed the codex to this:
https://make.wordpress.org/support/handbook/contributing-to-the-wordpress-codex/getting-started-codex/

Which worked. BUT. The dual slug made both posts show. You can still change it back and 'break' it.

I cannot reproduce this with pages alone:

https://make.wordpress.org/support/about/
https://make.wordpress.org/support/editor-access/about/

See? No issues.

I left it as https://make.wordpress.org/support/handbook/contributing-to-the-wordpress-codex/getting-started/ for now so you can see what I mean.

Just visit https://make.wordpress.org/support/handbook/getting-started/ and you'll see BOTH pages.

Change History (2)

#1 @SergeyBiryukov
5 years ago

I've tracked this down to a core issue, see #WP28611.

#2 @SergeyBiryukov
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [WP28803].

Note: See TracTickets for help on using tickets.