WordPress.org

Making WordPress.org

Opened 7 weeks ago

Closed 4 weeks ago

#5276 closed defect (fixed)

Emoji not working on BuddyPress.org

Reported by: johnjamesjacoby Owned by: dd32
Milestone: Priority: normal
Component: buddypress.org Keywords: needs-testing
Cc:

Description

Just noticed that emoji show up as ???? on BuddyPress.org.

Maybe related to r9949, or maybe they simply never worked and nobody tried until now.

See: https://buddypress.org/support/topic/login-redirect-issues/

Change History (3)

#1 @dd32
7 weeks ago

  • Status changed from assigned to accepted

#2 @dd32
7 weeks ago

This appears to be because the BuddyPress.org database tables are utf8 and not latin1 or utf8mb4 which support Emoji's.

So no, Emoji's didn't previously work as far as I can tell :)
I've also tried to force it, and it just doesn't save no matter what the collations are set to.

Looks like the best option forward here would be to perform the utf8->utf8mb4 upgrade for the appropriate tables. There's a bunch of sites on BuddyPress.org where the table collation are latin1 too, but they can probably be skipped.

r9949 was superseded by a change made directly in WordPress.org's HyperDB configuration.

#3 @dd32
4 weeks ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Did the conversion to utf8mb4 for the utf8 tables.

Example thread for those with access: https://buddypress.org/support/topic/pizza-emojis__trashed/?view=all

See also #1914

Note: See TracTickets for help on using tickets.