Making WordPress.org

Opened 3 years ago

Closed 18 months ago

#5465 closed enhancement (duplicate)

Theme Repository: Adjust design to differentiate between themes that support full-site editing, and those that don't

Reported by: kjellr's profile kjellr Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

When block-based themes start being introduced into the Theme Repository, it'll be important to help users identify which themes support full-site editing, and which don't.

The repository already has feature filters which can provide one method of differentiation. But we should consider additional UI/UX affordances to make the difference obvious to users as they browse and search.


This came up in the Block-based Themes meeting on Slack, and the group decided to open an issue for additional discussion.
https://wordpress.slack.com/archives/C02RP4Y3K/p1602088677269200

Change History (6)

#1 @williampatton
3 years ago

What kind of differing design do people think would be suitable here? Just adding some kind of a tag/badge icon to show it is FSE theme or something more significant?

#2 @kjellr
3 years ago

I haven't given this much thought yet, but my I think this could come in two parts:

  1. At the very least, I think it makes sense to introduce a new tab so folks can very easily find FSE themes. This could also introduce users to the concept of block-based themes — they'll need education about the difference. Here's a quick illustration to start this conversation:

http://cldup.com/YcUjSUpx7d.png

  1. For individual themes, I think we'll need some sort of obvious badge or indication that this theme is different. This could be an icon or other indication marker on the card itself. I personally think it should be pretty prominent because I expect brand new users will be very confused if they mistakenly switch from a block-based theme to one that doesn't support FSE. Again, some quick ideas:

http://cldup.com/PhyDQPdY4u.png

#3 @melchoyce
3 years ago

I think it's better to be explicit, and use the "Full Site Editing" label. It'd be great if we could make that a tool tip as well with a little more information about what that means. Another option could be to link that to the FSE theme category page you mocked up in 1, maybe with some additional supporting text (or at least a link to more information).

#4 @beafialho
3 years ago

Regarding the first mockup, I think what you have here is perfect. An important aspect is where the "Learn More" takes the user to. I also agree that the "Full Site Editing" label seems like the clearer option.

#5 @gibrown
2 years ago

  • Milestone set to Improved Search

#6 @poena
18 months ago

  • Keywords needs-design removed
  • Milestone Improved Search deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6330.

I will close this ticket as duplicate because there are more replies and a suggestion with 3 different approaches in this ticket:
https://meta.trac.wordpress.org/ticket/6330

Note: See TracTickets for help on using tickets.