WordPress.org

Making WordPress.org

#5474 closed enhancement (duplicate)

Make sure the reason for blocking/bozoing an account is always recorded and available

Reported by: tellyworth Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Currently it's possible to bozo or block a user from multiple places around w.org.

Generally when this is done from the forums, a reason is given by the mod/admin who blocked the user; and that reason is visible in the user notes on the /support/users page. This works fine and gives enough context.

The issue is that this reason isn't easily discoverable to admins and other users outside of the forums. And if a user is blocked from another part of the system, no reason or context will be recorded.

We need to make sure that a reason is always recorded for blocking and unblocking an account, and that the reason is more easily available. That probably means:

  1. Finding all the places where it's possible to block or bozo an account.
  2. Removing some of them, or linking them to a central place instead (such as the /support/users page).
  3. Displaying the user notes to admins in a few more places (such as profiles, and the plugin review tools).

Change History (2)

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


12 months ago

#2 @tellyworth
12 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4192.

Note: See TracTickets for help on using tickets.