Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#5537 closed defect (bug) (worksforme)

Impossible to edit a draft article on localized versions of HelpHub

Reported by: papicx's profile papicx Owned by:
Milestone: Priority: normal
Component: HelpHub (wordpress.org/documentation) Keywords:
Cc:

Description

Hello
for the past few days, I have not been able to edit the articles which are in draft. this one : https://fr.wordpress.org/support/article/glossary/

I get a blank page :(
I manage to edit an already published article, edit it and save it, but none of that for a draft article.

Attachments (2)

5537.png (36.4 KB) - added by ocean90 3 years ago.
10829891.html (348.5 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (10)

#1 @audrasjb
3 years ago

  • Component changed from General to HelpHub
  • Summary changed from impossible to edit a draft article to Impossible to edit a draft article on localized versions of HelpHub

For better context, this is happening on the French-localized version of HelpHub, in the "Articles" custom post type.

To reproduce the issue:

#2 @ocean90
3 years ago

This has already been logged a few times in our error channels and the reason is an out-of-memory fatal error (Allowed memory size of 268435456 bytes exhausted (tried to allocate 3186688 bytes)). Looking at the post, it has quite a few blocks and characters…

@ocean90
3 years ago

#3 @Otto42
3 years ago

That is approaching novella length. Maybe splitting this info up into multiple pages is a good first step.

#4 @papicx
3 years ago

Hello
Thank you for looking into this problem.
We could effectively reduce the size of this document considerably by removing blocks.
But how can we access the edition of this document, at least for some time, just necessary to remove the superfluous blocks and thus come down to a volume acceptable by the system?
Thank you in advance.

#5 @audrasjb
3 years ago

Hi @Otto42 @ocean90,

Is it possible to send us an HTML dump of the post?

Then we may be able to delete the existing one, and split it in two or three.

Thanks,
Jb

@ocean90
3 years ago

#6 @ocean90
3 years ago

@audrasjb Attached in 10829891.html.

#7 @audrasjb
3 years ago

Great, thanks! I'll delete the existing post and split it in several parts.
I think we can close this as fixed.

Many thanks for your help @ocean90 @Otto42 ♥️

#8 @audrasjb
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.