WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 2 weeks ago

Last modified 2 weeks ago

#5593 closed defect (fixed)

Contributor badges don't make your profile "public"

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: high
Component: Profiles Keywords:
Cc:

Description

Background: #4754, #4632, #4714, #4696.

As part of the changes in [dotorg15369], the Bio section on WP.org profiles is not displayed publicly when either of these conditions is true:

  • User is banned
  • User has no activity

The problem is that not all activity is currently reflected as such in profiles: submitting patches, GitHub PRs, translations will eventually get you a contributor badge, but not an activity entry. See #1664 or #5592 for example.

So a user can have a Core Contributor or Translator Contributor badge, but their Bio section is still not displayed publicly until they have at least one activity entry.

This seems wrong, as it implies that some activities are more "real" than others. Contributors should not be forced to a particular activity just for their profile to be public.

Change History (6)

This ticket was mentioned in Slack in #meta by sergey. View the logs.


7 months ago

#2 @tellyworth
7 months ago

  • Priority changed from normal to high

#3 @tellyworth
7 months ago

The proper fix here is making sure all relevant activity is reflected in profiles.

As an interim measure, what about adding a condition that will display a profile with no activity if it has badges?

#4 @dd32
7 months ago

The proper fix here is making sure all relevant activity is reflected in profiles.

Thinking out loud: Being granted a badge should be an activity item in and of itself, Bobby'); DROP TABLE wp_users;-- has gained the Pentesting badge!.

It looks like there's data stored of when a member was added to a team/group (which is what badges are based on) so we should be able to retrospectively add those activity items which would solve this problem and not require additional exceptions to be made to the indexing rules.

#5 @dd32
2 weeks ago

  • Resolution set to fixed
  • Status changed from new to closed

In [dotorg17822]:

Profiles: Display profile Bio & allow indexing of profile pages once a user has been assigned to a contributor group.

Fixes https://meta.trac.wordpress.org/ticket/5593

#6 @dd32
2 weeks ago

I should add I still think that more activity items should be added to track more contribution types.

As of [11270] GitHub PR & Issue creations will trigger the profiles to gain activity items, which will be triggered by things like those working on Documentation via Documentation-Issue-Tracker.

I'm still leaving this closed, even though I think more items should be caught, because they need their own ticket for the specific work required to add it.

Note: See TracTickets for help on using tickets.