WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 7 months ago

#5628 closed defect (wontfix)

Plugin Trac Side-by-Side Differences Not Working

Reported by: rumperuu Owned by:
Milestone: Priority: low
Component: Trac Keywords:
Cc:

Description

There seems to be a bug in the WordPress Plugin Trac diff tool.

Expected Behaviour

Setting the 'View differences' setting to 'side by side' should display file diffs side-by-side.

Actual Behaviour

Changing the setting has no effect.

Steps to Reproduce

Go to this page (or any diff), change the 'View differences' option in the top-right box and click 'Update'.

Additional Testing

I've verified that the bug exists in both Firefox 85.0.1 (with ad-block extensions disabled) and Chromium 88.0.4324.150 (fresh install, no extensions). There is no error output in the browser console.

Change History (1)

#1 @dd32
7 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

This is due to some caching functionality we've added to trac.

Trac by default is not cacheable, as every user (logged in or anonymous) is required to have an active cookie-based session. We've disabled that for logged out users, which means that anonymous users have no session storage.

The inline/side-by-side toggle sets a session state, and not a URL parameter, which as a result of the above caching changes causes the state to never be set/kept.

Logging in will resolve the issue, as then you've got a session that can have the preference saved in.

I'm going to close this as wontfix as Trac becomes unviable for use when it's not cached for our purposes, and modifying that functionality / removing it / etc isn't going to be worth the effort for the minimal number of people who it will benefit.

tl;dr: Log in, and it'll work.

Note: See TracTickets for help on using tickets.