WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#5648 closed defect (fixed)

Plugin rating showing 4 while all reviews are 5 stars.

Reported by: richardevcom Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hi there.
My plugin review page https://wordpress.org/support/plugin/add-polylang-support-for-customizer/reviews/ shows 4 stars publicly while it has only 5 star reviews. Not sure if this is a bug or some algorithm in place.

Change History (2)

#1 @dd32
8 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This has been caused by the most recent 1-star review being moved from being a review to being a support thread, and only some of the rating functions correctly excluding non-review ratings from the displayed numbers.

r17040dotorg

Ratings: Apply [15667] to all of the review methods, this ensures that the ratings counts only include actual reviews.

r17042dotorg
Ratings: Simplify by calculating some values in PHP based on the common cached self::get_rating_counts() instead of querying/caching it separately.

#2 @richardevcom
8 months ago

Thank you @dd32

Note: See TracTickets for help on using tickets.