WordPress.org

Making WordPress.org

Opened 7 months ago

Closed 7 months ago

#5732 closed defect (fixed)

Jetpack interstitial not translated on login

Reported by: dd32 Owned by: dd32
Milestone: Priority: normal
Component: Login & Authentication Keywords:
Cc:

Description

When the login screen is used in a non-en_US locale, the login screen is translated, however, if Jetpack isn't sure about the login being legitimate it'll prompt with a math problem to solve.

That math problem isn't translated. See screenshot.

Attachments (1)

Screen Shot 2021-05-10 at 11.34.26 am.png (451.0 KB) - added by dd32 7 months ago.

Download all attachments as: .zip

Change History (3)

#1 @dd32
7 months ago

Note: I'm assuming this is caused by the local selector on login not working for not-login pages, or not loading the Jetpack translation files, I'm making the assumption that these strings are translated in Jetpack.

#2 @dd32
7 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 10982:

Locale Switcher: Run earlier during WordPress bootstrap to ensure that the locale is switched prior to any other plugins executing code.

This ensures that it runs prior to Jetpack Protect which short circuits the request, and as a result can translate that page.

Fixes #5732.

Note: See TracTickets for help on using tickets.