Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#5743 closed defect (bug) (reported-upstream)

Not possible to subscribe to meetings of certain teams with Google Calendar

Reported by: psrpinto's profile psrpinto Owned by: psrpinto's profile psrpinto
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

The Upcoming WordPress Meetings page allows subscribing to the meetings of individual teams using Google Calendar.

However, for certain teams, Google Calendar erroneously states that the user does not have permission to subscribe to the calendar:

https://cldup.com/il52p1v9KK-3000x3000.png

Steps to reproduce:

  1. Go to https://make.wordpress.org/meetings
  2. Select Core under "Filter by team"
  3. Click on the "+ Google Calendar" button
  4. Click "Add" in the popup that appears
  5. The "Request access" popup is displayed

This issue affects the following teams:

  • All teams
  • Core
  • Meta

For other teams, subscribing with Google Calendar works as intended.

Change History (6)

#1 @tobifjellner
3 years ago

Seems to be those teams that continue sub-teams.

Version 0, edited 3 years ago by tobifjellner (next)

#2 @psrpinto
3 years ago

It seems the calendar has no concept of sub-teams, so I don't think that's the culprit.

#3 @psrpinto
3 years ago

I downloaded the meetings-core.ics file and put it on Dropbox. I then imported the Dropbox public link into Google Calendar:

(not an actual Dropbox link)
https://www.google.com/calendar/render?cid=webcal://www.dropbox.com/link-to-my-file.ics?dl=1

This worked correctly, which proves (?) the issue is not related to the content of the files, since the Dropbox file should be exactly the same as the file Google Calendar retrieves through the "+ Google Calendar" button:

https://www.google.com/calendar/render?cid=webcal://make.wordpress.org/meetings-core.ics

Maybe HTTP Response headers are the culprit. Will continue researching.

#4 @dd32
3 years ago

The meeting calendar is developed here: https://github.com/Automattic/meeting-calendar

@psrpinto Would you be able to create this ticket upstream there?

#5 @psrpinto
3 years ago

As requested, moved ticket to GitHub: https://github.com/Automattic/meeting-calendar/issues/115

Last edited 3 years ago by psrpinto (previous) (diff)

#6 @psrpinto
3 years ago

  • Resolution set to reported-upstream
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.