WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#579 closed defect (fixed)

"View version X details" for theme updates not working

Reported by: tollmanz Owned by:
Milestone: Priority: highest omg bbq
Component: Theme Directory Keywords:
Cc:

Description

When trying to see the theme details for a theme update, the iframe produces a white screen. This is due to forcing the "SAMEORIGIN" policy for "X-Frame-Options". Chrome produces the following error:

Refused to display 'https://wordpress.org/themes/make?' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

Firefox produces:

Load denied by X-Frame-Options: https://wordpress.org/themes/capture? does not permit cross-origin framing.

To reproduce:

  1. Add an older version of a theme on WordPress.org
  2. Go to Appearance > Themes
  3. For a theme producing an "Update Available" label, click "Theme Details"
  4. Click "View version X details" and you will see a blank lightbox

Change History (4)

#1 @ocean90
5 years ago

  • Priority changed from high to highest omg bbq

Noticed the same today.

#2 @netweb
5 years ago

  • Cc stephen@… added

#3 @Otto42
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This should be working now for the main site.

#4 @netweb
5 years ago

Yep, works for me :)

Note: See TracTickets for help on using tickets.