WordPress.org

Making WordPress.org

Opened 5 months ago

Closed 5 months ago

#5813 closed defect (duplicate)

Retire support profile pages

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: high
Component: Profiles Keywords: seo performance
Cc:

Description (last modified by jonoaldersonwp)

Every wp.org user gets two profile pages; a legacy 'forums' profile (e.g., https://wordpress.org/support/users/jonoaldersonwp/), and a page on the 'profiles' subdomain (e.g., https://profiles.wordpress.org/jonoaldersonwp/).

We should retire the former, in favour of the latter.

SEO challenges

From an SEO perspective, the sheer quantity of pages which Google has to discover, crawl through, and then dismiss, takes much-needed crawl budget from elsewhere on the site (at the time of writing, there are 30k forum pages which Google knows about, but hasn't yet crawled).

Furthermore, the legacy forums profile contains a series of sub-pages (e.g., https://wordpress.org/support/users/jonoaldersonwp/topics/, https://wordpress.org/support/users/jonoaldersonwp/reviews/), which collectively result in millions of thin, low-quality, and duplicate pages.

We've mitigated the impact somewhat through robots and canonical controls (support profiles are noindex'd), but this doesn't fix the underlying problem. It also doesn't address the UI/UX challenge and confusion which undoubtedly impacts our users, nor the performance/systems impact of maintaining and serving 10x the volume of pages that we need to.

Whilst these pages continue to exist, they'll continue to cripple other parts of wp.org.

Actions

I appreciate that there's undoubtedly complexity and legacy challenges that I don't have visibility of. Regardless, however, we need to:

  • Make sure that the profiles subdomain has equivalent/full functionality (for moderators/admins and users) so that the support profiles can be retired
  • 301 redirect support profiles to subdomain profiles
  • (eventually) update all template-level internal linking to the new URLs(s)

Change History (5)

#1 @fierevere
5 months ago

Actually there are many forum profiles for each user, each locale (rosetta) forum has its own profile for the user, and profiles are very different, they are informational for moderators and forum participants, while profiles.wordpress.org profile offers very limited information.

Maybe noindex will suffice for "SEO perspective" ?

#2 @jonoaldersonwp
5 months ago

The forum profiles (and their subpages) are already noindex'd. Updated the description to clarify! We need to not have two versions (and multiple subpages) of profiles.

We could certainly improve the features and information on the subdomain version, if that's missing something(s).

Last edited 5 months ago by jonoaldersonwp (previous) (diff)

#3 @jonoaldersonwp
5 months ago

  • Description modified (diff)

#5 @ocean90
5 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #518.

Note: See TracTickets for help on using tickets.