Making WordPress.org

Opened 3 years ago

Closed 4 months ago

#5861 closed defect (bug) (duplicate)

Redirect all remaining pages to HelpHub where possible

Reported by: tellyworth's profile tellyworth Owned by: jonoaldersonwp's profile jonoaldersonwp
Milestone: Priority: normal
Component: Codex Keywords:
Cc:

Description

Currently we have stub pages on Codex like this one:

https://codex.wordpress.org/New_To_WordPress_-_Where_to_Start

It includes a "this page has moved to" link, but doesn't automatically redirect. I believe it was done this way in order to retain the locale list on that page that links to translated versions of it such as https://codex.wordpress.org/es:Nuevo_en_WordPress_-_Por_dónde_empezar.

We should 30x redirect as many of these as possible to equivalent HelpHub pages. This probably requires building a table (spreadsheet, csv?) listing every page that needs to be redirected. Perhaps something like:

https://codex.wordpress.org/New_To_WordPress_-_Where_to_Start, 301, https://wordpress.org/support/article/new-to-wordpress-where-to-start/
https://codex.wordpress.org/es:Nuevo_en_WordPress_-_Por_dónde_empezar, 301, https://es.wordpress.org/support/article/new-to-wordpress-where-to-start/

Additionally there are other non-stub pages that should be redirected or retired. For example:

https://codex.wordpress.org/FAQ
https://codex.wordpress.org/Advanced_Topics
https://codex.wordpress.org/Developer_Documentation

Some of these are category pages, some not. Ideally, anything that can be redirected to HelpHub or other documentation, should be redirected. We'll need destinations for those, whether it's part of the same list or something else manually created. It might also be helpful to have a list of remaining pages, so they can be manually dealt with.

See also #5680, #4487

Change History (4)

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


3 years ago

#2 @dd32
5 months ago

I think it's time to redirect all of these pages, even if there's a localised variant.

I firmly believe the translated variants are no longer likely to be relevant / kept up to date / etc.

#3 @jonoaldersonwp
5 months ago

That would be the most amazing Christmas gift :D

#4 @dd32
4 months ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

If anyone wants to help with the final push towards this...

https://wordpress.slack.com/archives/C02RP4WU5/p1705987320931659

I'm going to mark this as a duplicate of #4487 since that's where the main discussion started.

Note: See TracTickets for help on using tickets.