WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#587 closed defect (duplicate)

Invalid MIME Type at ps.w.org

Reported by: extendwings Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

I got Content-Type: application/octet-stream as a MIME Type at https://ps.w.org/akismet/assets/icon-256x256.png?rev=969272
But it should be Content-Type image/png, I think.

Strangely, https://ps.w.org/jetpack/assets/screenshot-1.png?rev=815574 returns correct MIME Type.

Change History (4)

#1 @Otto42
3 years ago

The mime type is set by the client, typically, and this information is stored on the server. The SVN server will read the svn:mime-type property and serve it using that mime-type.

Now, while we recently made a change to the svn system to serve things with an automatic mime-type, I suspect that if the svn:mime-type is incorrectly set, then it will cause the system to override this. The ps.w.org CDN is simply mirroring that information.

In short, http://plugins.svn.wordpress.org/akismet/assets/icon-256x256.png has an svn:mime-type property set to application/octet-stream, while http://plugins.svn.wordpress.org/jetpack/assets/screenshot-1.png has its svn:mime-type set to image/png.

Note that http://plugins.svn.wordpress.org/jetpack/assets/icon-256x256.png has an svn:mime-type of application/octet-stream too, so I suspect that whatever client is being used to check in these files is forcing the svn:mime-type property here.

The fix is simple and detailed in this blog post: http://make.wordpress.org/plugins/2014/03/20/plugin-screenshots-downloading/

I think this is client dependent and we may want to force automatic mime-types all around somehow, but we'll need to investigate that. For the time being, plugin authors do have ultimate control over their mime-types and should set them correctly, or at least, not set them incorrectly.

Last edited 3 years ago by Otto42 (previous) (diff)

#2 @extendwings
3 years ago

Thanks @Otto42.

#3 @extendwings
3 years ago

  • Cc daisuke@… added

#4 @Otto42
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #151.

Note: See TracTickets for help on using tickets.