WordPress.org

Making WordPress.org

Opened 2 months ago

Closed 2 months ago

#5909 closed defect (fixed)

WordPress.org stats API returns version 15.6

Reported by: ramiy Owned by: dd32
Milestone: Priority: normal
Component: API Keywords:
Cc:

Description

The stats API https://api.wordpress.org/stats/wordpress/1.0/

Returns the following:

{
"15.6": 0.001,
"3.0": 0.098,
"3.1": 0.057,
"3.2": 0.053,
"3.3": 0.093,
"3.4": 0.115,
"3.5": 0.203,
"3.6": 0.112,
"3.7": 0.047,
"3.8": 0.15,
"3.9": 0.262,
"4.0": 0.238,
"4.1": 0.344,
"4.2": 0.396,
"4.3": 0.415,
"4.4": 0.753,
"4.5": 0.663,
"4.6": 0.702,
"4.7": 1.695,
"4.8": 1.517,
"4.9": 6.104,
"5.0": 1.402,
"5.1": 1.993,
"5.2": 4.028,
"5.3": 4.344,
"5.4": 6.192,
"5.5": 7.202,
"5.6": 5.713,
"5.7": 11.938,
"5.8": 43.167,
"5.9": 0.004
}

Version 15.6 should not be there.

Change History (5)

#1 @Otto42
2 months ago

We get lots and lots and lots of data reported back to us. We tend to ignore the invalid stuff. You probably should too. :)

#2 @ramiy
2 months ago

Can the API return only the valid WordPress versions?

#3 @dd32
2 months ago

  • Owner set to dd32
  • Status changed from new to accepted
  • Type changed from task to defect

I spotted this a few weeks ago on an internal API, but it hadn't reached the threshold for the public API's at that point..

Yes, there's some logic to exclude invalid reported data but unfortunately it looks like this particular version number is slipping through, and I'm not sure why :)

I'll get the data excluded and/or excluded from the API outputs at least.

#4 @ramiy
2 months ago

  • Keywords close added; dev-feedback removed

I see the API was fixed. Thank you guys, you can close this ticket.

BTY, I use this API in DisplayWP to generate wordpress stats and infographics. The wrong wordpress version has weird effect on the data.

Version 0, edited 2 months ago by ramiy (next)

#5 @dd32
2 months ago

  • Keywords close removed
  • Resolution set to fixed
  • Status changed from accepted to closed

It had a weird effect on the WordPress.org charts too :)

I removed the bad data a few days ago, and confirmed that code exists to exclude it from the index in future. I believe I know why it ended up in there in the first place too.

Note: See TracTickets for help on using tickets.