Making WordPress.org

Opened 4 years ago

Closed 2 months ago

#592 closed defect (worksforme)

Plugins API timeouts

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Component: API Keywords:


While browsing through the 'Popular' tab on the Plugins -> Add New screen in trunk, I'm noticing that most of the requests to the Plugins API are timing out. After the "An unexpected error occurred..." message is shown and I reload the page, the response seems to be very quick, likely due to a cache hit the second time around.

If you manually navigate to anything beyond about page 15 you should see the same behaviour if you don't get a response from a cache hit.

I'm using Query Monitor to monitor the HTTP requests to the API on these pages.

Change History (5)

#1 @johnbillion
4 years ago

I should add that what I mean by browsing is paging through the screens one after the other.

#2 @netweb
4 years ago

Not sure if this is the same issue exactly, waiting ~20 seconds for "Install Now" to turn up:


  • Add new plugin screen
  • Search for Akismet
  • Click "more details"
  • Wait for "Install Now" to show up


#3 follow-up: @obenland
2 months ago

After Shiny Updated v2 and the plugin directory update, is this still an issue?

#4 in reply to: ↑ 3 @dd32
2 months ago

I have a feeling that this was mostly fixed by the new plugin directory - although there are some API args which will be slower at high page numbers

#5 @obenland
2 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Let's keep an eye on it and close it for now. I couldn't reproduce it anymore either.

Note: See TracTickets for help on using tickets.