WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#5933 closed defect (fixed)

Theme Report button is hidden from the theme details page

Reported by: kafleg Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords: needs-patch
Cc:

Description

On the theme detail page, there was a button in the sidebar named, Report this theme. That button is now hidden with inline CSS.

I have no idea if any decision was made to hide that button. If not, we need that button visible. https://prnt.sc/1wyyxah

We need to remove the inline CSS to restore back, https://prnt.sc/1wyz3j1

Change History (6)

#1 @Otto42
3 months ago

It seems that @dd32 added this to the Custom CSS 6 months ago. I'm not certain why.

#2 @dd32
3 months ago

I added this over 6 months ago as no theme reports were being followed up on (in the previous 3 months at the time), and it was clear that no-one was using it in the correct manner (the most common complaints were that the theme didn't look like the preview, that they had a bad experience with the pro version, or that the author wasn't replying to the support threads).

The fact it's taken 6 months for anyone to notice that there hasn't been any reports just goes to show that no-one was actually monitoring it with any frequency.

I'm happy to re-enable the button if someone is intending on actually following up on the emails, but in general, the report functionality wasn't being used appropriately at all which suggests it was the wrong implementation regardless.

#3 @kafleg
3 months ago

As we all know that, we are working on making themes review automated. Once started, the effectiveness of Report this theme will be even more.
I think we need to restore back. And about the email follow-up, I can take care of them.

As @dd32 said, we usually get such reports for preview, pro version, etc. But still, we used to get reports related to theme errors. With that report, we used to delist/suspend or give a warning to the authors. I think that button is relevant.

#4 follow-up: @dd32
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

I've re-enabled the form.

I've also updated the warning label above the form to be much more explicit and blunt as to what the form can be used for, and added some garbage "what I need help with" options so that auto-replies/workflows can be setup in the Helpdesk software to auto-reply/auto-close as required.

Unfortunately, the form is now a bit broken as Jetpack no longer seems to be accepting pre-filled values from the URL, so you're going to get contextless reports.

See how it goes for the next few weeks, and we can revisit if the button needs a different flow added to it with the new review process.

#5 @kafleg
3 months ago

Thank you so much!

#6 in reply to: ↑ 4 @dd32
3 months ago

Replying to dd32:

Unfortunately, the form is now a bit broken as Jetpack no longer seems to be accepting pre-filled values from the URL, so you're going to get contextless reports.

Turned out that this is only for those with manage_options access for make.w.org/themes, as Jetpack no longer pre-fills forms if you're an admin of the site.. So it works fine for regular users, just not me :)

Last edited 3 months ago by dd32 (previous) (diff)
Note: See TracTickets for help on using tickets.