Making WordPress.org

Opened 2 years ago

Closed 6 months ago

#5958 closed enhancement (invalid)

improve Twitter #ILoveWP hashtag link on WP.org Testimonials page

Reported by: ixmati's profile ixmati Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Issue: The current link (https://twitter.com/hashtag/ILoveWP) to explore the #ILoveWP hashtag on the WP.org Testimonials page (https://wordpress.org/about/testimonials/) leads to "Top" tweets for that hashtag, which shows mostly older tweets.

Solution: Change the link to lead to the "Latest" tweets on the #ILoveWP hashtag to see more current tweets. Proposed new link: https://twitter.com/hashtag/ILoveWP?f=live

Attachments (2)

5958.diff (1.1 KB) - added by ixmati 2 years ago.
patch to address 5958
ILoveWPTwitterTop.png (413.8 KB) - added by ixmati 2 years ago.
View of "Top" tweets for the #ILoveWP hashtag as of 22 Nov 2021

Download all attachments as: .zip

Change History (14)

This ticket was mentioned in Slack in #meta by ixmati. View the logs.


2 years ago

#3 @ixmati
2 years ago

I was looking in the master branch in GitHub rather than trunk, so now I see latest changes. PR coming ASAP.

@ixmati
2 years ago

patch to address 5958

#4 @dd32
2 years ago

Linking to the Top rather than new was a bit intentional here unfortunately - anytime that a hashtag is used like that it tends to attract spam and unsavoury responses, so linking to the "latest and greatest" backfires often.

That's also why the page doesn't simply embed a river of all/recent tweets with the hashtag, as it's easy for things that we don't want to showcase to be shown.

@ixmati
2 years ago

View of "Top" tweets for the #ILoveWP hashtag as of 22 Nov 2021

#5 follow-up: @ixmati
2 years ago

I had that concern too about "Latest", but the first post under "Top" (at least for me) is totally unrelated to WordPress (something to do with West Palm Beach) and there are more down the "Top" list: https://meta.trac.wordpress.org/attachment/ticket/5958/ILoveWPTwitterTop.png

On the other hand, "Latest" does have a lot of tweets by KitchensinkWP.

Maybe the solution is not to link to the stream at all, but instead update the curation, which as per our discussion in Slack is likely a topic for the Marketing team to take up.

I'm ok with my patch here not moving forward as neither solution is great...

Last edited 2 years ago by ixmati (previous) (diff)

#6 in reply to: ↑ 5 ; follow-up: @dd32
2 years ago

Replying to ixmati:

I had that concern too about "Latest", but the first post under "Top" (at least for me) is totally unrelated to WordPress (something to do with West Palm Beach) and there are more down the "Top" list: https://meta.trac.wordpress.org/attachment/ticket/5958/ILoveWPTwitterTop.png

On the other hand, "Latest" does have a lot of tweets by KitchensinkWP.

Annoyingly, it looks like Twitter has a different set of tweets show up depending on the referrer being twitter or not.. The Top set of tweets included ILoveWPTwitterTop.png but in 3rd position for me (After Yoast and Josepha) and scrolling was a lot of relevant tweets. The latest was primarily hashtag spam at the time for me.

Looking at it now though, clicking through to Twitter from w.org (or pasting the URL in a browser, so there's no referrer info) shows a singular tweet for me under to which is at least WP related. Heading to the latest tab just shows a singular KitchenSink tweet..

More I try, it seems that about 25% of the time, Twitter loads more than 1 tweet, rest of the time just a singular one.

So yeah, neither situation is great.. Getting updated testimonials however would be brilliant and definitely something that would make the linked tweetstreams to be more useful again.

#7 @ixmati
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I see inconsistencies too, so I vote we just leave it as you have it then. Sorry to have opened this can of worms... I'll try to bring keeping testimonials more current up with the Marketing team.

Should we resolve this as wontfix?

#8 @ixmati
2 years ago

Oops, I think I accidentally applied a resolution. Maybe fine as "invalid".

#9 @dd32
2 years ago

  • Resolution changed from invalid to wontfix

Yeah, I'm good closing this as wontfix :)

#10 in reply to: ↑ 6 @SergeyBiryukov
2 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to dd32:

Looking at it now though, clicking through to Twitter from w.org (or pasting the URL in a browser, so there's no referrer info) shows a singular tweet for me under to which is at least WP related. Heading to the latest tab just shows a singular KitchenSink tweet..

More I try, it seems that about 25% of the time, Twitter loads more than 1 tweet, rest of the time just a singular one.

I might be missing something here, but https://twitter.com/search?q=%23ILoveWP&src=typed_query seems to work as expected for me, and consistently shows multiple tweets. Could that be the preferred option here?

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

#11 @ixmati
2 years ago

The inconsistent results are a bit maddening. I'm now seeing different results for various query structures than I saw before, and depending on whether I'm logged in to Twitter or not.

However I can confirm that I do see consistent results for the same query @SergeyBiryukov shared under all circumstances I've tried.

It does still however retunrn posts about West Palm Beach, but every modifier I add to remove such posts (eg, "-palm", "-palmbeach", etc) is maybe a bit too greedy (what if there were a West Palm Beach WordPress meetup?) or flip the view into chronological order so it surfaces the oldest results first, which seems unsatisfactory.

So I'm a +1 to changing the link to: https://twitter.com/search?q=(%23ILoveWP)&src=typed_query

#12 @coffee2code
6 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

In the intervening years since there was last discussion on this ticket, it has been made moot. The testimonials page now redirects to the "community" category archive on the News blog. That page has no link to Twitter (asides from the global footer) and makes no mention of the ILoveWP hashtag.

Note: See TracTickets for help on using tickets.