Making WordPress.org

Opened 2 years ago

Closed 3 months ago

#5997 closed defect (bug) (worksforme)

Photo Directory: Submission form delivering errors

Reported by: maverick3x6's profile maverick3x6 Owned by:
Milestone: Priority: normal
Component: Photo Directory Keywords:
Cc:

Description

Hey folks. I've been trying to submit photos to the photo directory. After I complete the form and hit submit, the page loads (I'm assuming it's uploading my photo), and then I'm delivered to this error:

ERR_HTTP2_PING_FAILED


The webpage at https://wordpress.org/photos/wp-admin/admin-ajax.php might be temporarily down or it may have moved permanently to a new web address.

Unsure it it's helpful, but my photos are generally 10+ MB each.

Attachments (1)

Screen Shot 2021-12-23 at 12.20.21 PM.png (67.4 KB) - added by maverick3x6 2 years ago.
Display of the error

Download all attachments as: .zip

Change History (5)

@maverick3x6
2 years ago

Display of the error

#1 follow-up: @maverick3x6
2 years ago

I tested this in Chrome and Firefox. Firefox worked fine, so this may be related to Chrome, specifically.

#2 in reply to: ↑ 1 @dd32
2 years ago

Replying to maverick3x6:

I tested this in Chrome and Firefox. Firefox worked fine, so this may be related to Chrome, specifically.

This is definitely a Chrome thing, and has been seen on WordPress.tv uploads too occasionally (Which is to WordPress.com servers, not WordPress.org), as well as on other websites that accept uploads.

I've not seen anyone actually be able to reproduce it when trying to, and from all I've read, my understanding is that it's an issue with a network timeout in the Chrome SPDY HTTP implementation. Specifically Chrome sends a "ping" packet at the start and end of a upload, and if either of those get lost or not returned that error is raised.

The only thing in common between this and WordPress.tv is... Chrome, nginx, WordPress, and admin-ajax.php, I don't think it'd be something related to admin-ajax, because this error is likely raised before the request ever gets to PHP, so it's probably somewhere in the Chrome => network => nginx stack.. and probably not going to be easily fixed here..

#3 @sabbir16
2 years ago

Tested using Chrome & EDGE browsers. The problem still exists.

Submission: https://prnt.sc/K3XK_y2IfMaY

Related: #6142

#4 @dd32
3 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Unfortunately I don't believe there's anything we can do here, without steps to reproduce.

As browsers & servers have changed a lot in two years, I'm going to close this as worksforme for now, but if it can be reproduced consistently with details of what triggers it, we can perhaps look further.

Note: See TracTickets for help on using tickets.