Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5998 closed defect (bug) (reported-upstream)

Hosting test results "Failed" for tests that do not perform assertions.

Reported by: costdev's profile costdev Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Several hosts have raised concerns about the "Failed" status showing on the Hosting Test Results page.

A recent commit in Core revealed test methods that do not perform assertions. Investigation and resolution of these test methods is ongoing.

However, in looking at the markup of the "Failed" status:

title="13432 tests, 0 failed, 30 errors"

From what I can tell:

  1. Risky tests are marked as errors.
  2. Errors create a "Failed" result.

Is this the intended behaviour, or can risky tests like these be excluded so as not to create concern with hosts?

Change History (5)

This ticket was mentioned in Slack in #hosting-community by costdev. View the logs.


2 years ago

This ticket was mentioned in Slack in #meta by costdev. View the logs.


2 years ago

#3 @dd32
2 years ago

The Test Reporter and Test Runner codebases live on GitHub:

https://github.com/WordPress/phpunit-test-reporter
https://github.com/WordPress/phpunit-test-runner

This probably should live on one of those repo's, and discussion had with the #hosting team on slack directly.

#4 @costdev
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks @dd32!

I've opened an issue on the Test Runner repo. Setting this ticket to invalid as the discussion and resolution belong elsewhere.

Last edited 2 years ago by costdev (previous) (diff)

#5 @dd32
2 years ago

  • Resolution changed from invalid to reported-upstream
Note: See TracTickets for help on using tickets.