WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 22 months ago

#6 closed enhancement (fixed)

Option to set default value of "Notify me of follow-up posts via email" in profile

Reported by: Daedalon Owned by: SergeyBiryukov
Milestone: Priority: low
Component: Support Forums Keywords:
Cc:

Description

When replying to a new topic on the support forums the checkbox "Notify me of follow-up posts via email" below the comment form is always unchecked by default.

WordPress.org profile options should allow setting this to be checked by default.

Change History (14)

#1 @iandunn
6 years ago

I'd go ever further and say that it should be turned on by default. A lot of times users will start a support thread and never come back. I think that often happens because the user didn't notice the box, and didn't remember to come back.

If it were on by default, then the return rate would be much better.

#2 @iandunn
6 years ago

  • Cc ian.dunn@… added

#3 @iandunn
6 years ago

Nevermind, it is turned on by default for new topics; it's only off by default for replies.

#4 follow-up: @Otto42
6 years ago

The box is checked by default on New Topics, but not on new replies. The thinking is that we want users asking questions to get notified, but we also don't want to accidentally start flooding the inbox of people answering questions unless they specifically opt-in to that.

Suggest wontfix on this one, works as intended.

#5 @iandunn
6 years ago

The OP was asking for a profile option so that individual users could have it enabled by default, which could still be a valid request. That would be more convenient than having to check if every time if a user decides they usually/always want to get reply notifications.

#6 @mordauk
6 years ago

  • Cc mordauk added

I'd love to see the profile option to make it default.

#7 @Daedalon
6 years ago

As Ian stated, the request is for a user-adjustable profile option. I've wanted the notifications close to 99% of the time. The profile option will save a lot of clicking.

#8 in reply to: ↑ 4 ; follow-up: @SergeyBiryukov
2 years ago

Replying to Otto42:

The box is checked by default on New Topics

This no longer seems to be the case after the upgrade to bbPress 2.x.

#9 in reply to: ↑ 8 ; follow-up: @netweb
2 years ago

Replying to SergeyBiryukov:

Replying to Otto42:

The box is checked by default on New Topics

This no longer seems to be the case after the upgrade to bbPress 2.x.

Here's the current state for each topic subscription checkbox occurrence:

  • New Topic - not checked
  • Edit Topic - is checked
  • New Reply - not checked
  • Edit Reply - not checked

#10 @SergeyBiryukov
22 months ago

  • Owner set to SergeyBiryukov
  • Status changed from new to accepted

#11 in reply to: ↑ 9 ; follow-up: @SergeyBiryukov
22 months ago

Replying to netweb:

Here's the current state for each topic subscription checkbox occurrence:

  • New Topic - not checked
  • Edit Topic - is checked
  • New Reply - not checked
  • Edit Reply - not checked

For me it's always unchecked (including Edit Topic, only "Keep a log of this edit" is checked there by default).

#12 in reply to: ↑ 11 @netweb
22 months ago

Replying to SergeyBiryukov:

For me it's always unchecked (including Edit Topic, only "Keep a log of this edit" is checked there by default).

It's inheriting the option by the look of things, if the user who created the topic checks the "Notify the author of follow-up replies via email" checkbox then I also see the checkbox checked, if not it remains unchecked:

Via a quick check of some of the topics in https://wordpress.org/support/view/no-replies/

Last edited 22 months ago by netweb (previous) (diff)

#13 @SergeyBiryukov
22 months ago

In 5608:

Support Forums: Check "Notify me of follow-up replies via email" checkbox for new topics by default.

See #6.

#14 @SergeyBiryukov
22 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 5657:

Support Forums: Add "Always notify me via email of follow-up posts in any topics I reply to" checkbox to user profile.

Fixes #6.

Note: See TracTickets for help on using tickets.