Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6009 closed defect (bug) (invalid)

Log-in should redirect back to the origin page in Forums

Reported by: alanjacobmathew's profile alanjacobmathew Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Currently login from support forums takes you back to the homepage, which is extra work for the user.

How To Reproduce

  • Make sure you are not logged in
  • Visit the support forum (here)
  • Click on 'Login to see the link' or the login button on right corner, or 'You must be logged in to reply this topic'
  • All 3 login instances takes the user to the home page.

The very reason the user logged in there is either to view the link, or to reply on the topic, but get's redirected to home page.

Change History (4)

#1 @Otto42
2 years ago

Can't reproduce this. Logging in there (in an incog window for testing) causes it to redirect back to the forum support topic.

Are you blocking the Referer header, perhaps with some privacy software? The login page checks the referer header, using wp_get_referer() and sets a redirect_to parameter on the login page, to take you back to where you were.

#2 @alanjacobmathew
2 years ago

Seems like the issue exists only on Brave Browser. Seems fine with edge.

But how does the redirects work properly from https://core.trac.wordpress.org, https://meta.trac.wodpress.org and Support Documentation even when using Brave.

#3 @Otto42
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I can't answer that because I don't use Brave or know the details of what it does. But in the end, we can only fix things for standard browser behavior, and sending referer headers is normal and has been for many decades.

I'm going to mark this invalid for now, but if anybody has suggestions on better ways to do things, please comment.

Last edited 2 years ago by Otto42 (previous) (diff)

#4 @Otto42
2 years ago

Just to add to this, some of the various sites explicitly add the redirect_to value in the path to login.w, which will be used instead of the referer. That may be why some of the Trac sites work, because they have explicit code to force the issue. This is because those sites aren't using WordPress, so we have special code on them to force these things to work properly.

Nevertheless, privacy blocking browsers will always cause these kinds of weird issues everywhere, in general, especially when they are trying too hard.

Note: See TracTickets for help on using tickets.