WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 6 months ago

#605 closed defect (worksforme)

Operation timed out after 15000 milliseconds

Reported by: Fogelholk Owned by:
Milestone: Priority: normal
Component: API Keywords:
Cc:

Description (last modified by ocean90)

We are a hosting company and are running a very large amount of wordpress sites from the same ip addresses, we have an issue where api.wordpress.org is very slow and causes
timeout when searching for plugins:

object(WP_Error)#4566 (2) {
	["errors":"WP_Error":private]=> array(1) {
		["http_request_failed"]=> array(1) {
			[0]=> string(71) "Operation timed out after 15000 milliseconds with 437066 bytes received"
		}
	}
	["error_data":"WP_Error":private]=> array(0) {
	}
}

Changing line 68 in wp-admin/includes/plugin-install.php to, for example, 60 makes the plugin-page work once again.

Seems like we are getting rate-limited on our web servers from downloading plugins and themes from wordpress.org.

If this is the wrong way of getting in touch with this problem, please direct me to the correct way.

Change History (6)

#1 @dd32
4 years ago

Howdy, Thanks for getting in touch :)

Appears that this is a duplicate of #592, so we're aware of the issue, it isn't rate-limiting, rather it's the WordPress.org API suffering some pain when the result isn't already in the cache.

Are you seeing timeouts on any other URL's? or just the requests originating from plugins_api()?

Last edited 4 years ago by dd32 (previous) (diff)

#2 @dd32
4 years ago

As a follow up question, are you seeing an acceptable download speed of plugin/theme packages?
I ask this as the plugin API response you're receiving there seems a little big at 437k, so network speed could be a factor in the increased timeouts you're seeing.

#3 @Fogelholk
4 years ago

Thanks for the reply! Sorry for missing out on #592.

On our ordinary servers (not web servers) we get 'full speed' from wordpress.org so to speak.
On all of our web servers running Wordpress we are getting limited to exactly 30 kBps while downloading plugins and themes from wordpress.org, tested with the BSD-command fetch (tested with http://wordpress.org/themes/download/ifeature.5.5.zip just now).
Downloading from sources other than wordpress.org on our web servers running Wordpress also gives us full speed. This is why I suspected rate-limiting :)

#4 @dd32
4 years ago

Thanks!

We don't have any rate limiting for WordPress.org API requests or downloads, we like to push updates & plugin/theme zip's out as fast as possible for a better user experience after all!

However, 30kB/s does sound suspiciously like a rate limiting, perhaps at some point between your web servers and the WordPress.org network..

We're also looking at ways to reduce the API response sizes to alleviate some issues, but that's not going to get rid of the limit you're running into.

#5 @ocean90
4 years ago

  • Description modified (diff)

#6 @dd32
6 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Marking this as closed 3 years later.

In the event any other Hosts run into this - when this was reported, and until today, there's been no rate limiting on the API interface - however other things may affect it.

If you're a host who is currently experiencing this issue, create a ticket with some details (traceroute, source IP, etc would be appreciated) and we'll look into it.

Note: See TracTickets for help on using tickets.